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SAS® Visual Analytics Step-by-Step Guide 
 
 
Selerity has created this Test Drive to illustrate the ease of use and versatility 
of SAS Visual Analytics (VA), hosted and managed by Selerity using Amazon 
Web Services. 
 
Selerity Test Drives are designed to be quick, useful and to the point and 
shouldn’t take longer than 20-30 minutes to complete once your environment 
is up and running. 
 
While SAS does support several industry standard web browsers, Selerity 
recommends the use of either Google Chrome or Firefox for the best 
experience during this Test Drive. 
 
This Test Drive starts with an introduction to creating Explorations and 
Reports using our demo data, then will describe how you can load your own 
data into this environment where you can see it come to life within SAS Visual 
Analytics.   
 
For those who want to take it further, we will be adding more advanced 
subjects into this Test Drive over time so refer to the Table of Contents below 
for what’s currently available. 
 
For further information on how Selerity can host and administer SAS Visual 
Analytics for your organisation, please contact us at www.selerity.com.au.  
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An Introduction to Explorations & Reports 
 
When logging in to SAS Visual Analytics for the first time you will be 
presented with “the Hub” which provides users with different applications to 
run based on their permissions.  To create new content users can select: 

• Data Explorer 
• Report Designer 
• Data Preparation (covered separately) 
• Create an Analytical Model (covered separately) 

 
Previously created content will also be available in the Hub to open, edit or 
view only (depending on your permissions). 
 
The Hub can be branded to include your company’s colours and logos so that 
it matches your own online applications, and Explorations or Reports can be 
embedded directly into your existing websites or called directly from a URL. 
 
The Data 
The data we use in this Test Drive is publically available Australian Football 
League (AFL) data.  We will look at match outcomes from the 2010-2014 
seasons, as well as injury data and game attendance. 
 
We also have data from the Australian Bureau of Statistics (ABS) to take a 
look at Mortgage related data in Australia from 2011. 
 
Later in this document we will describe how you can load your own data into 
this Test Drive to experiment with. 
 
The Who 
For this Introduction to Explorations & Reports we will be using the persona of 
Anna Marr, a SAS Analyst, and Visual Data Builder Administrator. 
 
The User Name is ‘anna’ and the password is ‘Password1’. 
 
Explorations vs Reports 
Explorations are for analysts who want the flexibility to perform adhoc work 
and explore and visualise patterns to unearth findings.  Explorations can be 
created, shared with others, exported to PDF or published to Word, Excel or 
PowerPoint documents.  Explorations can also be exported to a Report. 
 
Reports are typically more about laying out data on a screen in a logical way 
to be disseminated out to less technical and more business oriented 
audiences.  Recipients of reports can easily navigate up and down through 
interactive hierarchies, view the data using different charts, graphs, tables or 
geographic maps, and access it from either a web browser or a tablet (iPad or 
Android device). 
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Creating Explorations 
 
Create your own Exploration 
 
We now provide step-by-step instructions to walk you through the creation of 
an Exploration containing 4 different visualisations. 

Visualisation	1	–	How	do	venues	affect	an	AFL	Teams	performance?	

Identify	how	each	Team	performs	at	different	venues	
 
 

1) From the Hub, click ‘Data Explorer’ 
 

 
 
 

2) When prompted, click on “Select a Data Source…”, and select 
FOOTY_FINAL and click Open. 
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Once you have done this, you will see the names of the 11 different 
columns of data appearing in the left-hand pane of the Explorer tool.  Note 
that SAS has analysed the metadata and classified 6 of the 11 columns as 
‘Categories’ (or dimensions) and the remaining 5 as ‘Measures’ (numeric 
values). The number of distinct values are displayed next to each 
category. 

 
3) Whilst the classifications assigned are accurate, we need to make a 

minor alteration for an upcoming example.  
Right-click on actual_date and select ‘Duplicate Data Item’. 
 

 
 

4) In the ‘New Duplicate Item’ window, change the name to 
‘Game_Month’ and the format to ‘MMMYYYY’.  Click on ‘OK’. 
You should now see an additional variable called ‘Game_Month’ 
with 37 distinct values (37 months of data). 
 

 



	

 © 2013-2016 Scorpio Software Services Pty Ltd - All Rights Reserved                    7  7 

 
5) Single-click on ‘Win’.  In the Data Item Properties box at the bottom 

left corner of the screen, there are the property fields for Win 
(Name, Classification, Model Type, Format and Aggregation).  
Change the value of Name to ‘Number of Victories’ and the value of 
Format to ‘Comma’ (as shown below). 

 

 
	

The ‘Win’ variable is a simple 0-1 binary variable indicating a team’s 
victory in a match. 

 
6) Now it’s time to invoke the automatic charting tool.  Click on the 

“venue” variable in the left-hand pane and simply drag it onto the 
workspace canvas.  This gives you a frequency bar chart showing 
the number of rows that each Venue appears on. 
 

 
 

The automatic charting tool uses an in-built algorithm to return the best 
possible chart selection for the data.  If you want to change the chart type, 
use the toolbar buttons across the top of the canvas.  The ‘Roles’ tab on 
the right pane can be used to verify the Categories and Measures 
currently charted.   

 
7) Drag the ‘Number of Victories’ measure onto the canvas.  This will 

replace the default measure of ‘Frequency’ (or row count). 
 

8) Finally, drag in ‘Team’.  This will give you a lattice structure with 
several bar charts and a navigation tool at the top of the screen to 
navigate through the various charts. 
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9) In order to clean up our visualization, we will apply a ‘venue’ filter to 

stop the ‘missing’ venues from appearing in our visualization.  Right 
click on ‘venue’ in left hand pane and select ‘Add as Filter on 
Visualization’.   

 

 
 

10) This filter will then appear on the right-hand pane.  Uncheck the box 
for ‘Include missing values’ and the chart for ‘missing’ will 
disappear. 
 

 
 

11) Right-click on ‘venue’ once again in order to ‘Add as rank on 
visualization’.  On the right-hand pane under the Ranks tab, reduce 
the ‘Top 10’ value to ‘Top 3’. 
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12) Switch to the Properties tab on the right side of the screen, un-tick 
the “Generate graph title” box and name your visualization 
“Victories at Top 3 Venues”.  Add a title “Victories at Top 3 
Venues”.  This tab also enables the user to change several other 
features like bar direction and label properties, etc.  
 

13) Select ‘Save’ under the ‘File’ menu to save your exploration using 
the name “AFL Explorations” in “My Folder”. 
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Visualisation	2	–	How	many	tickets	are	we	expecting	to	sell	for	the	
2016	season?	

Calculate	total	monthly	attendance	of	AFL	matches.		Use	this	to	
forecast	the	attendance	for	the	2016	season.	
  

1) Click on the ‘New visualization’ button in the toolbar (which will 
create a second Visualisation inside the same Exploration) and 
maximise it from the top right corner of the new visualisation 
window.    

New Visualisation   Maximise 
 

2) Click on the Line chart icon in the chart types toolbar.   Note that 
when dragging several measures into the workspace, the automatic 
chart selector would by default select a line chart, however for this 
example we want to create a forecast so need to specifically select 
the Line Chart. 

 
3) Due to the steps carried out in the previous section, you should now 

have a ‘Game_Month’ variable.  Drag this onto the workspace 
canvas. 

 
4) Do the same for ‘attendance’.  You should see that Visual Analytics 

will automatically aggregate the ‘attendance’ variable according to 
whichever aggregation is chosen in the Data Item Properties for 
‘attendance’.  (The default is ‘sum’). 

 
5) Hover the mouse cursor over one of the data points on the line 

chart.  The format of the data appearing on the tooltip is in scientific 
notation. 
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In order to make this easier to read, single-click on the ‘attendance’ 
variable on the left pane. Change the Format property from Numeric 
to ‘Comma’, with a width of at least 8. Click ok.    
 
Hover your cursor over a data point again to spot the change. 
 

 
 

6) It’s now time to add the forecast.  Right-click anywhere on the chart 
then click ‘Show Forecast’. 
 

 
 
 

There should be a vertical line on the line chart, with values to the right 
hand side of this line being future predictions for attendance.  A blue area 
surrounds each prediction point, which is the 95% confidence interval. 

 
7) This forecast isn’t terribly useful to us, as it only predicts the next 6 

‘points’ (in this case these are months, since we’re using 
‘Game_Month’).  Click on the ‘Properties’ tab (right side of screen) 
and change the Forecasting Duration setting at the bottom of the 
tab from 6 to 12.  Click the big ‘tick’ next to the 12 and Intervals (to 
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deselect it) for changes to take affect. We now have a 12 month 
forecast, predicting total AFL game monthly attendance for the 
2015 season. 

 
8) Whilst still on the ‘Properties’ tab, change the name of this 

visualization to ‘Attendance Forecast’, and using the same method 
as before, give the visualization a title: ‘2016 Season Attendance 
Forecast’. 

 

 
 

9) Hover over the top right-hand corner of the visualization until you 
see a button for ‘Show Details’.  This setting is also available by 
right-clicking anywhere on the visualization.  Selecting ‘Show 
Details’, shows a data table at the bottom of the visualization, 
showing both the actual data points as well as the predicted points. 

 

 
 
The additional tab ‘Analysis’ on the details table in bottom screen gives 
information about the forecast algorithm used.  
 
Don’t forget to save your Exploration regularly. 
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Visualization	3	–	Attendees	Exposure	to	Sponsors	

AFL	team	major	sponsors	have	their	logo	printed	on	a	large	patch	on	
player	uniforms.		Show	the	number	of	attendees	who	have	been	
exposed	to	sponsors	branding	at	AFL	games.	
 

1) Click on the ‘New visualization’ button in the toolbar (which will 
create a third Visualisation inside the same Exploration) and 
maximise it from the top right corner of the new visualisation 
window.    

New Visualisation   Maximise 
 

2) Click on the cross tab icon in the chart types toolbar or click the 
drop-down list next to the word ‘Visualization 1’ (or select Crosstab 
from Visualization Menu).  
 

 
 

3) Create a new variable called ‘Year’ based on ‘actual_date’ 
formatted as Year.  This is done as before by right-clicking 
‘actual_date’ and selecting ‘Duplicate Data Item’.  Name the new 
item ‘Year’ and change the format to ‘Year’.  Click on ‘OK’ and 
when this is created, there should be 5 distinct values. 

 
4) Drag the new ‘Year’ data item to the far left column of the cross tab. 

 
5) Drag ‘Major’ (denoting the classification of Major sponsor) to the 

top of the cross tab. 
 

6) Finally, populate the body of the cross tab with ‘Attendance’. 
 

7) After this is done, click on the row header ‘Year’ to change the sort 
order to ‘descending’ (i.e. 2014 should be the top row). 

 
8) Click on the ‘Properties’ tab (right side of screen) and name this 

cross tab ‘Attendees Exposure to Sponsors.  Totals can also be 
added from this Properties tab for both rows and columns.  Place 
totals After data. Your exploration should look like below: 
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9) Re-save your Exploration. 
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Visualization	4	-	Team	Successes	vs	Injuries	

Identify	the	average	number	of	injuries	per	game	for	each	team	as	well	
as	the	total	victories	in	the	2014	season.	
 

1) Click on the ‘New visualization’ button in the toolbar (which will 
create a fourth Visualisation inside the same Exploration) and 
maximise it from the top right corner of the new visualisation 
window.    

New Visualisation   Maximise 
 

2) Click on the Treemap icon in the chart types toolbar. 
 

3) Drag ‘Team’ onto the canvas workspace to assign this data item to 
the ‘tiles’ role. 
 

4) Next, drag ‘Number of Victories’ onto the canvas.  This measure 
will be assigned to the tile size role (tile size represents the number 
of victories a team has). 

 
5) Since we are after a measure of the average number of injuries per 

game, single-click on the ‘num_injuries’ data item on the left pane.  
Change the Data Item Properties (lower left) as follows: 

• Name: Average Injuries 
• Format: Numeric (width 4) 
• Aggregation: Average 

 

 
 

6) Drag ‘Average Injuries’ onto the tree map.  When prompted, 
choose to add this measure as a ‘Color’. 
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7) The tree map is constructed in such a way that it is very easy to 
compare the two metrics for each AFL team.  From the last step, 
the number of injuries are taken as an average when aggregated. 
 

 
 

8) The only issue now is that the color gradient gives a white color for 
fewer injuries.  This is a default color gradient and doesn’t really suit 
the interpretation of the metric.  Right-click on the color gradient in 
the legend of the tree map and select ‘Edit Color Gradient’. 
 

 
 

9) Use the drop-down box to select the 4th color gradient (with red on 
the right-hand side, 4th selection from the list) and click ‘OK’. 
 

 
 

10) Finally, right-click on ‘Year’ in the data items list and select ‘Add as 
filter on visualization’.   

 
This will allow us to subset the data shown in the tree map to just 
the games from 2014.  When the ‘Filters’ tab becomes active, use 
the slider control or type in 2014 in the left hand box in order to 
subset the data to just 2014.  This is correct if you see that the data 



	

 © 2013-2016 Scorpio Software Services Pty Ltd - All Rights Reserved                    17  17 

in this visualization is only showing 20% of it’s total content  
(verified by the percentage bar in the bottom right corner of the 
screen). 
 

 
 

11) Click on the ‘Properties’ tab (right side of canvas) and name the 
tree map ‘Team Successes vs Injuries’ and as before, give the 
title ‘Average Match Injuries per Team 2014’. 
  

12) Click save. 
 

You now have 4 Visualisations within the Exploration you can switch between 
by selecting them from the bottom bar.  Click on each of the Visualisations to 
have them tiled in a single screen and save your exploration one final time. 
 
From here you could do a number of things with this Exploration: 

• Save it into a folder to be shared with other colleagues; 
• Select File / Email to email a link to other colleagues (they will be 

required to log in to Visual Analytics and have permissions to view the 
data); 

• Select File / Export to PDF; 
• Using the SAS Add-on for Microsoft Office you can open this 

Exploration and embed it within Word, Excel or PowerPoint and refresh 
the data whenever required; 

• Select File / Export to Report (which will create a Visual Analytics 
Report). 
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Building Interactive Reports 
 
Building Your Own Reports  
	
Reporting is a tool in Visual Analytics that is used to display findings for an 
end-user to interpret.  The process of building a Report is very similar to 
creating an Exploration and this section of the Test Drive will allow you to 
experience the functionality of an interactive report. 
 
Start by navigating back to the Hub by hitting the ‘Home’ button    then 
from the Hub, select ‘Report Designer’.  
 

 
 
Once in the reporting tool there are two key tabs on the left that users toggle 
between.  The Objects tab contains all the controls that can be dragged onto 
a Report canvas, and the Data tab contains the data fields. 
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Preparing	the	Data	
 

1) From the Data tab click on ‘Select a data source’ and chose the 
MORTGAGE_PAYMENTS_2011 table.  Once again Visual Analytics 
scans the data and classifies fields as Categories (Dimensions), or 
Measures (numeric fields).  If a numeric field was classified as a 
Measure when it should be a Category, simply right-click on the field 
and change it.  All Categories are displayed with the distinct counts 
alongside. 
 

       
 

2) If there are a large number of fields in the selected table then pull down 
the ‘Options’ arrow below the table name (right-most) and select 
‘Show or Hide items’. In this case un-tick ‘Time’ as we won’t be 
requiring this field. 
 

3) A default Measure of Frequency is always provided which is simply a 
row count.  In this case we want to rename the ‘count’ Measure so click 
on it and change the properties of this field (bottom left) so that Name 
is ‘Number of Mortgages’ and Format is ‘Comma’.  

 

 
 

4) Since our source data contains more data than is required for the 
purpose of our report, we will apply a data source filter in order to 
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reduce the amount of data behind the report.  This can yield 
performance benefits with large tables.   
 

5) Pull down the Data Source ‘Options’ arrow below the table name (top 
left) and click on ‘New Data Source Filter’.  

 

 
 

6) Under ‘Operators’, double click ‘Boolean’ and double click ‘AND’ to 
add a Boolean condition. 
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7) Double-click on ‘Character’ under ‘Data Items’ to select from the 

character data items of interest.  Single click on ‘dwelling_structure’.  
Directly underneath, there are SQL templates that can be used to 
select the syntax required. 
 

 
 

8) Double-click “dwelling_structure Notin ‘x’” to populate the first 
condition.  Use the drop-down box in the condition to select ‘Total 
occupied private dwellings’.  This will exclude all rows with this value 
from the data. 
 

 
 

 
9) Under Character again click on ‘mortgage_repayment_monthly’ and 

double click on the “mortgage_repayment_monthly Notin ‘x’” 
template to add this to the second condition. 
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10) Use the drop-down box in the second condition to select ‘Total’.  The 
bottom of the window should show the returned rows after the filter is 
applied.  This should read ‘Returned Rows: 160,260’ from ‘Total 
rows: 208,338’.  If this is the case, click ‘OK’ to apply the Data Source 
Filter.   

 

 
 

11) Select File and Save this report in ‘My Folder’ and call it ‘Mortgage 
Report Template’.  This can then be duplicated later and used to 
create new reports without having to set up the data fields each time. 

12) Select File and “Save As” again to save this report in ‘My Folder’ and 
call it ‘Mortgage Report’.  This is the Report we will continue to 
develop. 

 

Section	1	–	Simple	Charts	
 

1) Using the ‘Objects tab’ on the left-hand pane, drag a Pie Chart object 
out on to the canvas.  Initially the chart will be greyed out because 
there is not yet data associated with it. 

 
2) Using the ‘Data tab’, whilst pressing the CTRL button (COMMAND on a 

Mac), select ‘dwelling_structure’ and ‘Number of Mortgages’ then 
drag these onto the Pie Chart. 

 
3) Select the pie chart and click on the ‘Properties’ tab (top right).  Scroll 

down to the ‘legend’ section and select the placement in the middle-
right position. 
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4) Still on the ‘Properties’ tab, uncheck the box for ‘Create “other” slice 
for minimal values’. 

 

 
 

5)  Right-click on the ‘dwelling_structure’ heading in the pie chart legend 
and select ‘sort’ and then ‘ascending’. 

 
This pie chart shows the split of dwelling structures that mortgages related 
to in 2011, however we also want to add the mortgage repayment size.  
Other Objects can be added to a Report by either adding a new Section 
(page) to the report, or placing another Object above, below, left or right of 
the current object on the current Section (page). 

 
6) Using the ‘Objects tab’ on the left-hand pane, drag a Bar Chart object 

out on to the canvas and as you drag it around the canvas you will see 
you can place it above, below, left or right on the screen.  Drop it below 
the Pie Chart. 

 
7) Whilst pressing the CTRL button (COMMAND on a Mac), select, 

‘mortgage_repayment_monthly’ and ‘Number of Mortgages’ on the 
‘Data Tab’ and drag these onto the Bar Chart. 

 
8) Right-click on ‘mortgage_payment_monthly’ on the x-axis legend of 

the bar chart and select ‘sort’ and then ‘ascending’.  Note that the 
sorting has occurred based on alphabetic criteria and not numeric. 

 
9)  Navigate to the ‘Data tab’ and right click on 

‘mortgage_repayment_monthly’.  Select ‘New Custom Sort’.  Drag 
the Category Data from left to right in the correct sort order (shown 
below):  
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10) Repeat step 8 above and choose descending. Notice changes in the 
sort order on the x-axis. 
 

Now we want to link the two charts together so that when we select a 
segment on the Pie Chart it filters the data shown in the bar chart to just 
that segment. 

 
11) Select the Pie Chart and then click on the View menu (top left) and 

select ‘Show Interactions’.  Hove the Pie Chart and when you see a 
pencil, draw (by dragging) a line from the Pie Chart to the Bar Chart 
and then Close the Interactions window. 
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Now when we click on a segment in the Pie Chart we see the distribution 
of monthly mortgage payments just for that dwelling structure.  This 
information is still being displayed for all Australia so we might now want to 
subset it by State. 

 
12)  In the Objects tab (top left), drag ‘Drop-Down List’ and drop it in the 

dark grey header section above Section 1.  Objects dragged above 
Section 1 relate to all sections (pages) of the report, whereas objects 
dropped below Section 1 (and above the Pie Chart) relate just to this 
section (page). 
 

13) From the Data tab, drag and drop ‘state’ onto this Drop-Down List.  
Users can now select which State in Australia the data relates to. 

 
14) Remember to save your Report regularly. 

 

Section	2	–	Adding	Hierarchies	
 
Let’s create a second Section (page) to our report by clicking on the + next to 
Section 1.  Section Names can be added within the Properties Tab (top right) 
and leave Layout set to ‘Tiled’ for now. 
 
This data has been downloaded from the Australian Bureau of Statistics 
(ABS) and contains State / SA4 / SA3 / SA2 regions (as defined by ABS).  We 
can create an adhoc hierarchy using these fields allowing users to drill up and 
down through this data. 
 

1) Within the Data tab (top left), pull down the data source ‘Options’ 
menu under the table name and select ‘New Hierarchy’.  Name the 
new hierarchy ‘Region Hierarchy’ and then double click ‘state’ then 
‘sa4_region’ then ‘sa3-region’ then ‘sa2_region’.  The new hierarchy 
should look like this: 

 

 
 
Click OK to save the new hierarchy. 
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2) Within the Objects tab, drag and drop a Crosstab object onto Section 2, 
then from the Data tab drag and drop the Region Hierarchy.  As the 
filter at the top of the screen (Drop-Down List) relates to all Sections 
this will need to be reset to “Clear Filter”. 
 

3) Right click on the Drop-Down List at the top of the page and select 
‘Delete Drop-Down List 1’.  We won’t be needing this again. 
 

4) From the Data tab, drag ‘dwelling_structure’ to the top row of the 
crosstab and then “Number of Mortgages” to the centre of the crosstab.  
Users can now drill up and down through this data much the same way 
that a pivot table works in Microsoft Excel (without the need to build an 
OLAP cube). 

 

 
 
Click on the + sign beside each name to drill down. 

 

 
 

5) Time to save your report again. 
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Adding	Geographical	Regions	
 
SAS Visual Analytics offers a very comprehensive ability to map geographic 
data onto maps.  This test drive will demonstrate a very small part of this 
functionality as an introduction to the subject.  First we need to create some 
Geography data types. 
 

1) From the Data tab, right-click on sa3_region and select ‘Duplicate 
Data Item’.  (We can no longer change the categorisation of 
sa3_region as it is being used within our Hierarchy). Rename the new 
‘sa3_region(1)’ using the lower left properties and call it ‘sa3_map’. 
 

2) Now we can right-click on ‘sa3_map’ and change the categorisation to 
Geography and chose “Subdivision (State, Province) Names’.  
From the pull down list, select ‘Australia (SA3)’.  We now have a new 
categorisation of Geography containing sa3_map (334 regions). 

 

 
 

 
 

3) Click on Section 1 (our original page with the pie chart and bar chart).  
From the Objects tab (top left) drag ‘Geo Region Map’ and drop it down 
the left hand side of the existing two charts.  From the Data Tab select 
both ‘sa3_map’ and ‘Number of Mortgages’ and drag them onto the 
Geo Region Map.  This process may take 15-30 seconds to initially 
load on your Test Drive server. 
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The regions shown across Australia are now colour coded based on 
number of mortgages in place during 2011.  For the final step we want to 
link the Geo Region Map to the pie chart (which is mapped to the bar 
chart) so they all work together. 

 
1) Click on the Geo Region Map and then select the Interactions tab (top 

right) and press the Interactions View button. If this is not visible, click 
on the down-arrow found in the right-most, then select Interactions 
from the drop-down list.  

 

 
 

4)  Hover on the Geo Region Map until the pencil icon appears. Drag the 
pencil icon to draw a line from the Geo Region Map to the Pie Chart 
and click Close. 
 

 
 

Zoom in using the Geo Region Map and find the region you live in 
Australia.  When you click on that region and hover over the dot in the 
centre of the region you will see the region name and the number of 
mortgages registered within that region (as at 2011). 
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The Pie Chart will update to show the breakdown of Dwelling Structures 
for that region, and the Bar Chart will show the distribution of monthly 
mortgage payments for that region. 
 
You may need to right click on the ‘mortgage_replayment_monthly’ legend 
across the bottom of the Bar Chart and click Sort / Ascending again after 
the Geo Region Map was added. 
 

 
 

5) Time to save that report again. 
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Section	3	–	Twitter	Word	Clouds	
 
SAS Visual Analytics provides quick and simple access to Twitter feeds in 
order to understand what the public have to say on a specific topic.  If you 
don’t have a Twitter account or are not interested in this information you can 
skip to the next section of this Test Drive. 
 

2) Create a third Section (page) using the + button next to Section 2. 
 

3) At the top of the Data Tab (left panel), select the ‘Add Data Source’ 
button under the current table name. 

 

 
 

4) Select Twitter from the lower right corner of this window. 
 

 
 

5) Authorise SAS Visual Analytics to use your Twitter account (read only). 
 

6) If you get redirected back to a SAS Visual Analytics Marketing page, 
close this window and Select Twitter again from the lower right corner 
of the Visual Analytics Test Drive. 
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7) Enter a Search Term of your choice (for example “Tony Abbott”) and 
press OK to create a new dataset within Visual Analytics containing 
data imported from Twitter concerning Tony Abbott.  

 

 
 
Note: If an error message appears after clicking OK, just put any 
number after the LASR table name (e.g., Twitter_Output3 or 
Twitter_Output_3).  

 

 
 

8) From the Objects Tab, drag and drop ‘Word Cloud’ onto the Section 3 
canvas. 

 
9) From the Data Tab, drag and drop ‘body’ then ‘retweetcount’ onto the 

Word Cloud.  Add ‘authorfollowercount’ and chose ‘Color’. 
 

 
 
The Word Cloud report should look like below:  
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This now shows the body of the top recent tweets relating to Tony 
Abbott.  This size of the text increases as the message is retweeted 
and the colour of the text indicates the combined following of the 
authors.  Further analysis can be done to isolate authors. 

 
10) From the Objects Tab (left panel), drag a ‘List Table’ to be positioned 

under the Word Cloud. 
 

11) From the Data Tab (left panel), select author, authorname, 
authordescription, authorlocation, authorfollowercount, and 
authorfriendcount.  Drag them all out onto the List Table. 

 
12) Click on the List Table and then select the Interactions tab (top right 

panel) and press ‘Interactions View’.  If this is not visible, click on the 
down-arrow found in the right-most, then select Interactions from the 
drop-down list.  

 

 
 

13) Hover on the List Table until a pencil icon is showing. Drag the pencil 
icon to draw a line from the List Table to the Word Cloud and then click 
Close. 
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14) Click on the authorfollowercount heading in the List Table to resort the 
authors with the largest followings to the top.  Select specific authors or 
groups of authors and watch the Word Cloud update. 
 

 
 

15) Save the report. 
 
How much do you know about what people are saying about your company, 
your products and your services?  Trying adapting the Twitter feed to use your 
company details. 
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Loading Your Data 
 
Getting data into Visual Analytics is straightforward.  It can be done by 
importing local files from your desktop, accessing an API (like Twitter), or by 
creating a query using multiple data sources from a remote database.  In this 
Test Drive, we’ll provide an introduction to the first method to get you started 
using your own data with SAS Visual Analytics. 
 
Importing Local Files 

Example:	Importing	a	local	CSV	file	
 
Importing data can be done from multiple locations, including when creating 
Explorations or Reports (or using Data Preparation which we will cover in a 
separate Test Drive).  The process is the same for each of these regardless of 
which web application is used. 
 
To keep it simple we’ll be importing data straight from the Exploration web 
application. 
 

1) Start by navigating back to the hub by hitting the ‘Home’ button.  
Once back at the hub, select ‘Data Explorer’.  
 

2) There will be a prompt to ‘Select a Data Source’.  Click the prompt. 
 

 
 
The next window will show any recently used data sources as well as having 
a section on the right-hand side where you can opt to import different data 
types from either ‘Local’ (your workstation), ‘Server’ (the Test Drive server) 
or ‘Social Media’. 
 

3) Click on ‘Text Files (*.csv, *.txt)’ under Local. 
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4) Navigate to a relevant csv file on your local PC that you would like to 
upload/import. You can also have the csv file zipped before uploading 
to reduce transfer time. To avoid errors in uploading, ensure that the:  

a. csv file has the column names on the first row; 
b. data starts on the second row; and  
c. there are no special characters or spaces in the column/field 

names. 
 

5) You will then see a window where you can change preferences such 
as the delimiter used in the file, the number or records to import, etc. 
Make sure you are: 

a.  using the correct delimiter (a comma for this case),  
b. uploading the csv file in the correct folder which is:  

“/Users Folder/anna/My Folder” and 
c. accepting all of the default settings. (The output table name will 

default to your csv filename, which you can change if needed.) 
Click ‘OK’. 
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6) The dataset has now been loaded into SAS Visual Analytics and you’re 
ready to start exploring the data. After clicking ‘OK’, you will see your 
table in the Data Explorer window. 
 

 
Bear in mind that this is the process for importing a csv/text file. These steps 
are almost exactly the same for any of the other compatible file types, but with 
slightly different options, for example – importing an XLSX file enables the 
user to select which worksheets should be imported.   
 
Importing directly from a database involves providing host details as well as 
user login credentials.  
 
We hope you enjoy the remainder of your SAS Visual Analytics Test Drive 
and please contact us at www.selerity.com.au if you have any comments, 
suggestions or queries. 


